TP9SA Mod 2 Light Mount issue

Having and issue with your Canik Firearm? Post your problem here for other members to assist with finding a resolution.
Post Reply
colonel00
Member
Posts: 12
Joined: Sun Apr 07, 2019 1:36 am

TP9SA Mod 2 Light Mount issue

Post by colonel00 » Sun Apr 07, 2019 1:44 am

Apologies in advance, new to the forum and trying to search has only lead to one thread but it was kind of different from my issue.

I have a TP9SA Mod 2 in FDE. For the life of me, I cannot get weapon lights to mount to the Pic rail properly. It seems the recesses in the rail are too shallow for mounts. Mostly I have a few Olight lights which that other thread showed mounted fine to other models.

Is this just an issue with the model I have?

Aside from breaking out the Dremel to remove some material, are there any solutions to getting a light to fit properly?

I have several Canik pistols at the top of my "next to by" list like the SFX and the Elite Combat. Is mounting a weapon light an absolute deal breaker? No. However, it just seems odd that the gun I have has a pic rail that seems to be "out of spec".

Again, sorry if this has been asked before. I've searched the Googleborg and it seems this has come up a time or two but I can't really find an answer to whether this is a systemic issue I should take up with Canik or if it was just an issue with my gun.
0 x

User avatar
Janik
Staff Member
Posts: 1355
Joined: Mon Apr 23, 2018 4:59 pm
Founding Member #: 001
Location: Iowa
Contact:

Re: TP9SA Mod 2 Light Mount issue

Post by Janik » Sun Apr 07, 2019 9:51 am

Interesting, I haven't heard of this issue yet. I do have a few Olights, a couple PL MIni's and a Couple PL MIni 2's. No issues at all mounting them on any of my guns. I did have an SA Mod2 for awhile but sold it off to a family member who really wanted it. So unfortunately I can't offer any real assistance at this point. Which Olight do you have? I know my Mini's come with two different mounting brackets to accommodate different rails. I don't have the literature in front of me at the moment, but I believe one is recommended for 1911's, the other for Glock, etc. I have always left the plate that comes attached on the light and have mounted it to my Caniks and other handguns without issue. I tried the other one in the package once, but it would not fit properly on any of my guns. It was too tall and wouldn't allow the light to latch in place. I also assume that your rail could potentially be out of spec. Haven't come across that issue yet here on the forum or in our FB group, but I imagine it is possible.
0 x

User avatar
TL1000RSquid
Global Moderator
Posts: 734
Joined: Wed Apr 25, 2018 2:24 pm
Founding Member #: 007
Location: Texas

Re: TP9SA Mod 2 Light Mount issue

Post by TL1000RSquid » Sun Apr 07, 2019 12:12 pm

I have the original SA not the Mod2 no issues here I've had the mini and full size pl2's on it, tlr1hl, tlr8, and a few amzon cheapies mounted on it at one point. I think its possible its out of spec and would contact Canik/Century.
0 x

colonel00
Member
Posts: 12
Joined: Sun Apr 07, 2019 1:36 am

Re: TP9SA Mod 2 Light Mount issue

Post by colonel00 » Sun Apr 07, 2019 12:50 pm

Thanks for the replies. I should have included examples of the lights but you hit on them already. I've tried a PL-2 as well as two PL Mini 2's. I also have an Inforce APLC (Glock). On the Olights, I've tried both the Glock and the Pic retention bars but both are too "tall". The Inforce has a cross bolt that runs across the recess in the Pic rail and threads in the other side. With the light on the rail, you can see that the recess in the Pic rail is way too shallow for the bolt to clear.

I'm out of town right now but I'll get some photos and measurements when I get home. From what I can find on the internet, the depth of the recesses in the rail should be 3mm (.118 in).
1 x

nctrailboss
Member
Posts: 21
Joined: Tue Jan 22, 2019 7:51 pm

Re: TP9SA Mod 2 Light Mount issue

Post by nctrailboss » Sun Apr 07, 2019 8:57 pm

Same issue on my DA ,the slots are a little shallow and the Olight sits askew.L just run it without the little wedge in place.It fits tight enough to not move.
0 x

colonel00
Member
Posts: 12
Joined: Sun Apr 07, 2019 1:36 am

Re: TP9SA Mod 2 Light Mount issue

Post by colonel00 » Sun Apr 07, 2019 9:26 pm

nctrailboss wrote:
Sun Apr 07, 2019 8:57 pm
Same issue on my DA ,the slots are a little shallow and the Olight sits askew.L just run it without the little wedge in place.It fits tight enough to not move.
I tried that with the PL2 but that barely lasted a few magazines before it came flying off.
0 x

qballbandit
Supporting Member
Supporting Member
Posts: 102
Joined: Tue Dec 04, 2018 8:52 pm
Location: Illinois

Re: TP9SA Mod 2 Light Mount issue

Post by qballbandit » Mon Apr 08, 2019 9:03 pm

I have the issue on my DA as well, with the Olight PL-Mini, so I just leave off the little plate that fits in the recess, and snap it into the rail. It is pretty snug, and I am not holstering this gun on the regular (nightstand gun), so not worried. I have not knocked it off yet with all the dry fire practice I do, though if I wanted to, I could slide it off the front with enough force.
Good luck, hope you get it resolved.

It does fit on my Elite-S with the mount plate, so the DA must have been milled differently? The recesses are noticeably different on the two guns.

Neil 8-)
1 x

colonel00
Member
Posts: 12
Joined: Sun Apr 07, 2019 1:36 am

Re: TP9SA Mod 2 Light Mount issue

Post by colonel00 » Thu Apr 11, 2019 12:49 am

Well, finally home and taking some quick measurements, the valleys/recesses (is there a proper term) in the pic rail is only 1.60-1.7mm deep instead of the spec 3mm. I reached out to Century Arms the other day and they have responded with the expected "What light are you trying to mount? Did it come with different inserts?" so I'm replying now with my findings and we'll see what they can do.

Actually, here's a quick photo that I believe illustrates the issue. Please correct me if I'm wrong but I think that the recesses should go all the way to the horizontal edge that sticks out the farthest. You can see that there quite a bit of material before you get to that line.

Image
0 x

User avatar
zeda3000
Member
Posts: 39
Joined: Tue Apr 16, 2019 4:42 am
Location: Turkey

Re: TP9SA Mod 2 Light Mount issue

Post by zeda3000 » Tue Apr 16, 2019 5:29 am

i have Olights also. But problem not in olights. I have also Cheap Flashlight from Aliexpress and i have this small angle too. I think there is some minnor problem of Canik Pic Rail molding. Soon I will speak with Canik Factory about this problem.

Image
0 x

User avatar
GaDawg0513
Member
Posts: 47
Joined: Thu Mar 14, 2019 2:21 pm
Location: Nebraska

Re: TP9SA Mod 2 Light Mount issue

Post by GaDawg0513 » Tue Apr 16, 2019 5:04 pm

I bought the PL-2 Valkyrie from O-light in Marietta, GA and had the same problems. I had to return the O-light for a refund. Their final email stated they went to a local gun store to fit a Valkyrie and the slide cuts were not deep enough to accept the glock & 1913 rail adapters for their light. They suggested I go to a gunsmith to have the slide cuts deepened to accept a glock or 1913 cut accessories.
0 x
Image

colonel00
Member
Posts: 12
Joined: Sun Apr 07, 2019 1:36 am

Re: TP9SA Mod 2 Light Mount issue

Post by colonel00 » Tue Apr 16, 2019 5:38 pm

GaDawg0513 wrote:
Tue Apr 16, 2019 5:04 pm
I bought the PL-2 Valkyrie from O-light in Marietta, GA and had the same problems. I had to return the O-light for a refund. Their final email stated they went to a local gun store to fit a Valkyrie and the slide cuts were not deep enough to accept the glock & 1913 rail adapters for their light. They suggested I go to a gunsmith to have the slide cuts deepened to accept a glock or 1913 cut accessories.
Interesting. Which Canik model was it? Did you contact Canik or Century by any chance?

I'm still waiting to hear back from Century. They responded pretty quickly last week to ask what lights I was trying to mount but when I replied with photos of the issue, I haven't heard a peep.

To me it seems like a rare issue from reports so far but it's definitely a manufacturer's defect if the same lights work fine on other people's guns.

Here are some more photos to show how bad it is. The PL-Mini doesn't even stay attached.

Image

Image

Image

Image
0 x

User avatar
GaDawg0513
Member
Posts: 47
Joined: Thu Mar 14, 2019 2:21 pm
Location: Nebraska

Re: TP9SA Mod 2 Light Mount issue

Post by GaDawg0513 » Tue Apr 16, 2019 5:41 pm

Tp9sfx. Haven't contacted Canik yet.
0 x
Image

Post Reply