Page 1 of 1

Second muzzle brake session.

Posted: Tue Oct 09, 2018 8:53 pm
by Retiredtrooper
Installed 11# recoil spring. First shot with 147gr Freedom ammo ejected, but barely. I thought just MAYBE it would work, but 6/12 failed to eject. Thinking that the spring needed some breaking in, I ran 125 rounds of Speer Lawman, which ran perfectly. Switched back to the Freedom.....same old same old. :roll: I can now do one of two things, either buy hotter ammo, or heat up the brake and remove it altogether. The reason for this is that I'm literally setting on a hoard of the Freedom, which will run fine in this gun without the brake. It also cycles my G19 without fail. I went to WalMart this morning and picked up 900 rounds of 124gr Winchester NATO which I'm going to give a run tomorrow. If the accuracy is there, I may run this until I can't get any more, THEN drop the brake. Things are really up in the air right now. More to report after the next session. BTW, had re-installed the brake using Loctite 246 which took the heat and didn't loosen up a bit.

Re: Second muzzle brake session.

Posted: Wed Oct 10, 2018 4:54 pm
by LT USN (Ret.)
Thx for the range report.

Re: Second muzzle brake session.

Posted: Sun Nov 18, 2018 11:06 am
by Eyetat
How dirty is the gun?mine was dirty real dirty fast.

Re: Second muzzle brake session.

Posted: Sun Nov 18, 2018 9:19 pm
by Retiredtrooper
The NATO ammo dirties up the works real quick, including the feed ramp. Since I started shooting that, I'm cleaning after every range session/match. Works very nicely with the compensator. So does the Speer Lawman 147.