Page 1 of 1

failure to eject

Posted: Thu Jan 10, 2019 8:57 pm
by inletguy
Sorry, just joined, and put my message in , I believe, wrong place.

after cleaning, lubing my new SFX today...had two failures to eject in probably first 40 rounds...then it ran fine for rest of 100 rounds total. Came home, and cleaned, lubed again. Can anyone help with my problem...shooting S &B 124 grain which has been great for my Walthers.

Help, please

Re: failure to eject

Posted: Thu Jan 10, 2019 9:30 pm
by Janik
Common "issue" with new Caniks is the RSA. Not that there's anything necessarily wrong with them, but they are inherently stiff. Any new Canik I get, I run a couple boxes of hotter ammo through them, such as NATO 124gr. After that, they will eat anything. From my understanding, they are over sprung because of the area they are manufactured. Apparently, in that region, they tend to run hot ammo regularly. But why they put such a stiff spring in a competition gun is beyond me. A carry gun, sure, as most of us use premium ammo for that. Anyway, the RSA just needs to loosen up a bit. I learned this lesson early on, and I now religiously run a box or two of NATO or Speer Lawman first. After that, I have no issues at all with the weakest of ammo. I had that issue with my first Elite, and was bummed with the weak ejections and stove pipes. I believe I was running WWB 115gr through it at the time. Did a little digging and read others were having the same issue. So I bought a couple boxes of NATO and after that, it ate everything.

So don't be concerned yet. It's more than likely the RSA. If it should continue to give you a problem though, contact Century Arms. They sent me a reduced power RSA for my SFx because I was concerned about running weaker ammo for competition. But, like every Canik I own, I ran a couple boxes of NATO through it first and it eats anything, and I never did put the reduced power RSA in it.